2.Lodop页面总提示"未安装"或"请升级"的可能原因


 
1.高版本的火狐谷歌不再支持np插件方式,需要安装使用C-Lodop,Lodop与C-Lodop的区别参考http://www.c-lodop.com/faq/pp21.html
总提示"CLodop云打印服务(localhost本地)未安装启动!",或”CLodop云打印服务需升级“,参考http://www.c-lodop.com/faq/pp5.html
重启C-Lodop本地服务的方法,参考http://www.c-lodop.com/faq/pp4.html
2:使用的64位浏览器,但提供给客户安装的Lodop是32位的,反之也一样,Lodop位数要与浏览器位数一致,与操作系统位数无关, 总之尽量按Lodopfuncs.js提示的去做,不要人为自行判断。使用最新版的LodopFuncs.js,让js自己判断使用Lodop还是C-Lodop以及Lodop的位数
3:IE11以上浏览器,则要求用Lodop6.1.5.8以上版本附带的lodopfuncs.js文件。
4:IE浏览器,注意查看是否误选了“ActiveX筛选”,查看途径:IE菜单->工具->ActiveX筛选(默认情况下不选)。
5:所安装Lodop版本号小于判断语句中比较的版本号,这种情况提示的是“请升级”(不是“未安装”)。
6:判断控件已安装(一般由LodopFuncs.js中getlodop实现,也有自己编写)的js过程有错误,建议对比lodop在线例子: http://www.c-lodop.com/LodopDemo.html
7:如果是谷歌浏览器自动升级到Chrome33后出现问题,请参考如下文章解决: http://blog.sina.com.cn/s/blog_721e77e50101cnxb.html
8:谷歌浏览器,进入chrome://settings/content 看看是否阻止了lodop或所有插件(另外看看谷歌启动时是否带了--disable-plugins 参数)。
9:谷歌浏览器,看看是否安装了ActiveX for Chrome扩展件,参考这篇文章解决一下:http://blog.sina.com.cn/s/blog_721e77e5010175ge.html
10:安装的Lodop版本太低(小于6.0.5.8)老控件受浏览器安全设置影响较大,尽量用Lodop最新版。
11:控件主文件(CAOSOFT_WEB_PRINT_lodop.ocx)被安全软件等警示(老版本易发生)且被操作者误选禁用或隔离。
12:如果是谷歌和火狐出问题,检查object是否设置为style:display:none 此时改用getlodop无参数方式可解决。
13:如果是Opera浏览器,查看一下是否开启了Turbo模式(或越野模式)。